码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 3746 Cyclic Nacklace (KMP求循环节)

时间:2014-09-12 17:12:53      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   div   

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:
bubuko.com,布布扣

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input

3 aaa abca abcde
 

Sample Output

0 2 5 题意:求让你添加几个字母使得字符串能构成由若干个循环节组成的字符串 思路:已经有了推论出知道:i-next[i]是最小循环节,需要增加一些特判,当i-next[i]==1的时候代表的是类似“aaa”的字符串,当next[i]==0的时候就需要我们添加字符串的长度 单位了,否则就是判断本身就能构成若干个循环节和需要再添加构成一个循环节
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;

char pattern[maxn];  
int next[maxn];

void getNext() {
	int m = strlen(pattern);
	next[0] = 0, next[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = next[i];
		while (j && pattern[i] != pattern[j])
			j = next[j];
		next[i+1] = pattern[i] == pattern[j] ? j+1 : 0; 
	}

	int len = m - next[m];
	if (len == 1)
		printf("0\n");
	else if (len == m)
		printf("%d\n", m);
	else if (next[m] > 0 && (m % len) == 0)
		printf("0\n");
	else {
		int num = m / len;
		printf("%d\n", len-(m-len*num));
	}
}

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%s", pattern);		
		getNext();
	}
	return 0;
}


HDU - 3746 Cyclic Nacklace (KMP求循环节)

标签:des   style   http   color   io   os   ar   for   div   

原文地址:http://blog.csdn.net/u011345136/article/details/39231397

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!