码迷,mamicode.com
首页 > 其他好文 > 详细

分支-05. 用天平找小球

时间:2014-09-12 18:43:13      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   java   ar   strong   div   sp   log   

三个球A、B、C,大小形状相同且其中有一个球与其他球重量不同。要求找出这个不一样的球。

输入格式:输入在一行中给出3个正整数,顺序对应球A、B、C的重量。

输出格式:在一行中输出唯一的那个不一样的球。

输入样例:1 1 2
输出样例:C
import java.util.Scanner;  
public class Main 
{
    public static void main(String[] args)
    {
        Scanner ball = new Scanner(System.in);
        String balls = ball.nextLine();
        String[] b = balls.split(" ");
        if(b.length == 3)
        {
            int b1 = Integer.parseInt(b[0]);
            int b2 = Integer.parseInt(b[1]);
            int b3 = Integer.parseInt(b[2]);
            if(b1==b2 || b1==b3 || b2==b3)
            {
                if(b1==b2)
                 System.out.print("C");
                else
                {
                    if(b1==b3)
                     System.out.print("B");
                    else
                     System.out.print("A");
                }
            }
            else
             System.out.print("Input error!");
        } 
    }
}

 

分支-05. 用天平找小球

标签:style   blog   color   java   ar   strong   div   sp   log   

原文地址:http://www.cnblogs.com/lsgcoder101/p/3968722.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!