码迷,mamicode.com
首页 > 其他好文 > 详细

统计难题

时间:2017-11-01 22:50:46      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:new   入门   字典树   abs   字符串   输入数据   panel   cout   input   

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
Output对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc
Sample Output
2
3
1
0

字典树入门题,提交g++,总是超空间,提交c++就对了。。倒是不难,却搞得我一直在想办法。。

代码:
#include <iostream>
#include <cstdlib>
#include <string>

using namespace std;
struct DTree
{
    int c;
    DTree *next[26];
};
DTree *CreatDTree()
{
    DTree *head = new DTree;
    head -> c = 0;
    for(int i = 0;i < 26;i ++)
    {
        head -> next[i] = NULL;
    }
    return head;
}
DTree *SetDTree(DTree *head,string a)
{
    DTree *h = head;
    for(int i = 0;i < a.size();i ++)
    {
        if(head -> next[a[i] - a] == NULL)
        {
            head -> next[a[i] - a] = CreatDTree();
        }
        head = head -> next[a[i] - a];
        head -> c ++;
    }
    return h;
}
int Count(DTree *head,string b)
{
    for(int i = 0;i < b.size();i ++)
    {
        head = head -> next[b[i] - a];
        if(head == NULL) return 0;
    }
    return head -> c;
}
int main()
{
    string a,b;
    DTree *head = CreatDTree();
    while(getline(cin,a)&&a.size())
    {
        head = SetDTree(head,a);
    }
    while(cin>>b)
    {
        cout<<Count(head,b)<<endl;
    }
}

 

统计难题

标签:new   入门   字典树   abs   字符串   输入数据   panel   cout   input   

原文地址:http://www.cnblogs.com/8023spz/p/7768876.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!