码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2485:Highways(模板题)

时间:2014-09-12 21:57:04      阅读:298      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

http://poj.org/problem?id=2485

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

最小生成树问题:(用prim算法)

/*题意:Flatopia岛要修路,这个岛上有n个城市,要求修完路后,各城市之间可以相互到达,且修的总
路程最短.
求所修路中的最长的路段*/

#include <iostream>
#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
using namespace std;
int map[501][501];
int n,dis[501],v[501];
void prim()
{
    int min,sum=-1,k;
    for(int i=1; i<=n; i++)
    {
        v[i]=0;
        dis[i]=INF;
    }
    for(int i=1; i<=n; i++)
        dis[i]=map[1][i];
    v[1]=1;
    for(int j=1; j<n; j++)
    {
        min=INF;
        for(int i=1; i<=n; i++)
        {
            if(v[i]==0&&dis[i]<min)
            {
                k=i;
                min=dis[i];
            }
        }
        if(sum<min)
            sum=min;
        v[k]=1;
        for(int i=1; i<=n; i++)
        {
            if(v[i]==0&&map[k][i]<dis[i])
            {
                dis[i]=map[k][i];
            }
        }
    }
    cout<<sum<<endl;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        prim();
    }
    return 0;
}

 

POJ2485:Highways(模板题)

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://www.cnblogs.com/zhangmingcheng/p/3969074.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!