码迷,mamicode.com
首页 > 其他好文 > 详细

Period

时间:2017-11-05 12:11:16      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:nsis   each   前缀和   first   kmp   ever   odi   str   lines   

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

InputThe input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
OutputFor each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目意思是找出字符串中由两个或以上相同的子字符串组成的前缀,输出前缀长度及其中相同的子字符串的个数。
kmp next记录相同前缀和后缀的重叠,i - next[i]为子字符串大小,如果i能够被其整除,且除后结果不为1,就能输出。


代码:


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char str[1000000];
int next[1000000],n;
void findnext()
{
    int k = -1,i = 0;
    next[0] = -1;
    while(i<n){
    if(str[i] == str[k] || k == -1)
    {
        i++;
        k++;
        next[i] = k;
    }
    else k = next[k];
    }
}
int main()
{
    int k = 1;
    while(~scanf("%d",&n)&& n)
    {
        scanf("%s",str);
        findnext();
        printf("Test case #%d\n",k++);
        for(int i = 1;i <= n;i ++)
        {
            int temp=i-next[i];
            if(i%temp==0 && i/temp>1)
            printf("%d %d\n",i,i/temp);
        }
        puts("");
    }
}

 

Period

标签:nsis   each   前缀和   first   kmp   ever   odi   str   lines   

原文地址:http://www.cnblogs.com/8023spz/p/7786887.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!