码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 2752 Seek the Name, Seek the Fame (KMP的next[]应用)

时间:2014-09-13 10:40:55      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   os   ar   for   div   sp   cti   

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father‘s name and the mother‘s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:求既匹配字符串前缀又匹配后缀的字符串的长度
思路:其实next[]数组就表示的是最长的前缀和后缀匹配,那么只要next[]数组的值不为0的话,就代表有前后缀匹配,递归下去,当然整个字符串也符合条件
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 400010;

char pattern[maxn];
int next[maxn], flag;

void getNext() {
	int m = strlen(pattern);
	next[0] = next[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = next[i];
		while (j && pattern[i] != pattern[j]) 
			j = next[j];
		next[i+1] = pattern[i] == pattern[j] ? j+1 : 0;
	}
}

void dfs(int len) {
	if (len == 0)
		return;
	dfs(next[len]);
	if (!flag) {
		printf("%d", len);
		flag = 1;
	}
	else printf(" %d", len);
}

int main() {
	while (scanf("%s", pattern) != EOF) {
		getNext();
		int len = strlen(pattern);
		flag = 0;
		dfs(len);
		printf("\n");
	}	
	return 0;
}


POJ - 2752 Seek the Name, Seek the Fame (KMP的next[]应用)

标签:des   style   io   os   ar   for   div   sp   cti   

原文地址:http://blog.csdn.net/u011345136/article/details/39249525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!