码迷,mamicode.com
首页 > 其他好文 > 详细

Cyclic Nacklace

时间:2017-11-07 01:33:45      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:sel   appears   pre   nal   最小   everyone   add   scanf   must   

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:
技术分享

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet.Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5

求最少添加几个字符使之可以成为循环的首尾相接的串,需要求最小循环节,借助kmp,砍掉重叠的后缀,观察剩下的串能否被总长度整除,如果能则表示已经是循环的了,如果不能再减去余数就是需要添加的个数

代码:

#include <stdio.h>
#include <string.h>
char a[100005];
int next[100005];
void getnext(int n,char *s)
{
    int i = 0,k = -1;
    next[i] = -1;
    while(i < n)
    {
        if(k == -1 || s[k] == s[i])
        {
            next[++ i] = ++k;
        }
        else k = next[k];
    }
}
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t --)
    {
        scanf("%s",a);
        int len = strlen(a);
        getnext(len,a);

        int d = len - next[len];//去掉最大重叠后缀 剩下的为最小循环节
        if(!next[len])printf("%d\n",len); //无最大重叠后缀,那么最细小循环节就是本身
        else
        {
            if(len%d)printf("%d\n",d - len % d);///总长度能整除最小循环节则满足,不能则需要最小循环节减去余数 
            else printf("0\n");
        }
    }
}

 

Cyclic Nacklace

标签:sel   appears   pre   nal   最小   everyone   add   scanf   must   

原文地址:http://www.cnblogs.com/8023spz/p/7795975.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!