码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3780

时间:2014-09-13 18:44:15      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   io   os   ar   for   div   sp   

Paint the Grid Again

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Leo has a grid with N × N cells. He wants to paint each cell with a specific color (either black or white).

Leo has a magical brush which can paint any row with black color, or any column with white color. Each time he uses the brush, the previous color of cells will be covered by the new color. Since the magic of the brush is limited, each row and each column can only be painted at most once. The cells were painted in some other color (neither black nor white) initially.

Please write a program to find out the way to paint the grid.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 500). Then N lines follow. Each line contains a string with N characters. Each character is either ‘X‘ (black) or ‘O‘ (white) indicates the color of the cells should be painted to, after Leo finished his painting.

Output

For each test case, output "No solution" if it is impossible to find a way to paint the grid.

Otherwise, output the solution with minimum number of painting operations. Each operation is either "R#" (paint in a row) or "C#" (paint in a column), "#" is the index (1-based) of the row/column. Use exactly one space to separate each operation.

Among all possible solutions, you should choose the lexicographically smallest one. A solution X is lexicographically smaller than Y if there exists an integer k, the first k - 1 operations of X and Y are the same. The k-th operation of X is smaller than the k-th in Y. The operation in a column is always smaller than the operation in a row. If two operations have the same type, the one with smaller index of row/column is the lexicographically smaller one.

Sample Input

2
2
XX
OX
2
XO
OX

Sample Output

R2 C1 R1
No solution


题目意思:
给出n*n的方块图,初始时方块图颜色为空,给出图最终颜色,X表示黑色,O表示白色,Leo有一把刷子,只能横着刷或者竖着刷,横着刷为黑色,竖着刷为白色,问Leo能否刷成最终图的颜色。

思路:
对每一次刷都是刷一行或者一列,那么从最终图向初始时倒着算,那么最后一次刷肯定是一行或者一列,找到这一行或者一列就删去正行或者整列,依次向前,若能把图删完那么倒着输出刷的顺序,否则输出No solution。 注意:该题说输出时按照字典序输出,那么每次尽可能先刷最下面的行或者最右边的列。

代码有点乱。。
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
#include <stack>
using namespace std;


struct node{
    int mm;
    char c;
};

main()
{
    int t, n, i, j, k;
    stack<node>st;
    char map[505][505];
    cin>>t;
    while(t--){
        while(!st.empty()) st.pop();
        scanf("%d",&n);
        for(i=0;i<=n;i++){
            for(j=0;j<=n;j++) map[i][j]=X;
        }
        for(i=1;i<=n;i++) scanf("%s",map[i]+1);
        
        int num=0, u, f1, f2;
        while(num<n*n){    
            for(i=n;i>=1;i--){             //
                if(map[i][0]==.) continue;
                f1=1;
                for(j=1;j<=n;j++){
                    if(map[i][j]==.) continue;
                    if(map[i][j]!=X){
                        f1=0;break;
                    }
                }
                if(f1){
                    u=i;break;
                }
            }
            if(f1) {
                node p;
                for(j=1;j<=n;j++){
                    if(map[u][j]!=.) {
                        map[u][j]=.;num++;
                    }
                }
                
                p.c=R;p.mm=u;map[u][0]=.;
                st.push(p);continue;
            }
            int f2=1;
            for(j=n;j>=1;j--){             //
                f2=1;
                if(map[0][j]==.) continue;
                for(i=1;i<=n;i++){
                    if(map[i][j]==.) continue;
                    if(map[i][j]!=O){
                        f2=0;break;
                    }
                }
                if(f2){
                    u=j;break;
                }
            }
            if(f2) {
                node p;
                for(i=1;i<=n;i++){
                    if(map[i][u]!=.) {
                        map[i][u]=.;num++;
                    }
                }
                
                p.c=C;p.mm=u;map[0][u]=.;
                st.push(p);continue;
            }
            if(!f1&&!f2) break;
        
        }
        if(num<n*n) printf("No solution\n");
        else{
            node p;
            p=st.top();st.pop();
            printf("%c%d",p.c,p.mm);
            while(!st.empty()){
                p=st.top();
                st.pop();
                printf(" %c%d",p.c,p.mm);
            }
            cout<<endl;
        }
    }
}

 

ZOJ 3780

标签:style   blog   color   io   os   ar   for   div   sp   

原文地址:http://www.cnblogs.com/qq1012662902/p/3970126.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!