标签:hdu 博弈
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4994
Problem Description
Nim is a mathematical game of strategy in which two players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.
---Wikipedia
Today, Nim takes revenge on you. The rule of the game has changed a little: the player must remove the objects from the current head(first) heap. Only the current head heap is empty can the player start to remove from the new head heap. As usual, the player
who takes the last object wins.
Input
The first line contains a single integer T, indicating the number of test cases.
Each test case begins with an integer N, indicating the number of heaps. Then N integer Ai follows, indicating the number of each heap successively, and the player must take objects in this order, from the first to the last.
[Technical Specification]
1. 1 <= T <= 100
2. 1 <= N <= 1 000
3. 1 <= Ai <= 1 000 000 000
Output
For each test case, output “Yes” if the first player can always win, otherwise “No”.
Sample Input
Sample Output
Source
官方题解:
Nim游戏变成从前往后有序的,谁是winner?
如果当前堆数目为1,玩家没有选择,只能取走。如此直到第一个不为1的堆,则当前回合行动者必胜。考虑之后的状态为S,如果S为必败态,则玩家可以取完当前堆,否则,将当前堆数目变为1。
复杂度:O(N)
代码如下:
#include <cstdio>
int main()
{
int t;
int n, num;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int flag = 0;
int k = 0;
for(int i = 1; i <= n; i++)
{
scanf("%d",&num);
if(num > 1)
{
flag = 1;
}
if(!flag)
k++;
}
if(flag)
{
if(k%2 == 0)
printf("Yes\n");
else
printf("No\n");
}
else
{
if(k%2)
printf("Yes\n");
else
printf("No\n");
}
}
return 0;
}
hdu 4994 Revenge of Nim(博弈)
标签:hdu 博弈
原文地址:http://blog.csdn.net/u012860063/article/details/39253851