码迷,mamicode.com
首页 > 其他好文 > 详细

poj2349最小生成树prim

时间:2017-11-09 22:48:37      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:namespace   splay   comm   ted   table   key   term   not   ima   

Arctic Network
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 23359   Accepted: 7170

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

Source

技术分享
#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define inf 1<<29
using namespace std;
int n,s,p,x[510],y[510];
double dis[510][510],ans[510];
void prim()
{
    bool hh[510];
    int v;
    for(int i=1;i<=p;i++)
    {
        ans[i]=dis[1][i];
        hh[i]=0;            
    }          
    for(int i=1;i<=p
    ;i++)
    {
        int mi=inf;
        for(int j=1;j<=p;j++)
        {
            if(ans[j]<mi&&!hh[j]) {mi=ans[j];v=j;}        
        }        
        hh[v]=1;
        for(int j=1;j<=p;j++)
        {
            if(!hh[j]&&dis[v][j]<ans[j]) ans[j]=dis[v][j];        
        }
        
    }
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&s,&p);          
        for(int i=1;i<=p;i++) scanf("%d%d",&x[i],&y[i]);
        for(int i=1;i<=p;i++)
        {
            for(int j=1;j<=p;j++)
            {
                dis[i][j]=sqrt((double)(x[i]-x[j])*(double)(x[i]-x[j])+(double)(y[i]-y[j])*(double)(y[i]-y[j]));              
            }        
        }      
        prim();
        sort(ans+1,ans+p+1);
        printf("%.2f\n",ans[p-s+1]);       
    }

    return 0;
}
View Code

 

poj2349最小生成树prim

标签:namespace   splay   comm   ted   table   key   term   not   ima   

原文地址:http://www.cnblogs.com/SX0427/p/7811209.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!