码迷,mamicode.com
首页 > 其他好文 > 详细

【bzoj1441】Min 扩展裴蜀定理

时间:2017-11-10 21:40:21      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:数字   names   bzoj   bsp   题目   content   集合   print   sof   

题目描述

给出n个数(A1...An)现求一组整数序列(X1...Xn)使得S=A1*X1+...An*Xn>0,且S的值最小

输入

第一行给出数字N,代表有N个数 下面一行给出N个数

输出

S的最小值

样例输入

2
4059 -1782

样例输出

99


题解

扩展裴蜀定理

裴蜀定理:二元一次不定方程 $ax+by=c$ 存在整数解的充分必要条件是 $\gcd(a,b)|c$。

扩展裴蜀定理:改成n元一次不定方程,结论依然成立。

证明: $a_1x_1+a_2x_2$ 的取值范围为 $k·\gcd(a_1,a_2)$ ,相当于 $\gcd(a_1,a_2)$ 为新的系数, $k$ 为新的未知数,相当于合并了两个未知数。这样合并到低就是 $\gcd(a_1,a_2,...,a_n)x$,因此有整数解的充要条件是 $\gcd(a_1,a_2,...,a_n)|c$。

因此 $S$ 的取值集合就是 $\gcd(a_1,a_2,...,a_n)$ 的倍数,最小的正整数 $S$ 就是 $\gcd(a_1,a_2,...,a_n)$ 

#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
    int n , x , ans = 0;
    scanf("%d" , &n);
    while(n -- ) scanf("%d" , &x) , ans = __gcd(ans , abs(x));
    printf("%d\n" , ans);
    return 0;
}

 

 

【bzoj1441】Min 扩展裴蜀定理

标签:数字   names   bzoj   bsp   题目   content   集合   print   sof   

原文地址:http://www.cnblogs.com/GXZlegend/p/7816147.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!