码迷,mamicode.com
首页 > 其他好文 > 详细

acm_icpc网络赛第二站:鞍山赛区

时间:2014-09-14 00:10:26      阅读:309      评论:0      收藏:0      [点我收藏+]

标签:acm   icpc   

 

这次。。啥也不说了 chp他两上课来晚了。。我也没账号。。开场半小时才开始做的,就敲了一道水题。。然后他们两一直在商量那道计算几何。。最后还是没出来。

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 140    Accepted Submission(s): 93
Special Judge


Problem Description
Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that, the i-th song scored ai will add 0.95^(i-1)*ai to your total score.

Now you are given the task to write a calculator for this system.


 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a1, a2, ..., an separated by a single space, denoting the score of each song.

T<=20, n<=50, 1<=ai<=500.


 

Output
For each test case, output one line for the answer.

Your answers will be considered correct if its absolute error is smaller than 1e-5.


 

Sample Input
1 2 530 478


 

Sample Output
984.1000000000

 

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <stack>
using namespace std;
#define LL long long
int a[555];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int t,n;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i=0;i<n;i++)
			cin>>a[i];
		sort(a,a+n,cmp);
		double sum=0;
		for(int i=0;i<n;i++)
			sum+=(pow(0.95,i)*a[i]);
		printf("%.10lf\n",sum);
	}
	return 0;
}

 

acm_icpc网络赛第二站:鞍山赛区

标签:acm   icpc   

原文地址:http://blog.csdn.net/qq_16255321/article/details/39257219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!