标签:des style blog http color io os ar for
Problem Description
I used to think I could be anything, but now I know that I couldn‘t do anything. So I started traveling.
The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph
has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.
If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn‘t contain it.
Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node
a and node b.
T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.
Your answer will be accepted if its absolute error doesn‘t exceed 1e-5.
Sample Input
2
5 10 100
1 2
2 3
3 4
4 5
1 5
2 4
3 5
2 5
1 4
1 3
10 10 10
1 2
2 3
3 4
4 5
5 6
6 7
7 8
8 9
9 10
4 9
Sample Output
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.0000000000
0.6993317967
0.5864284952
0.4440860821
0.2275896991
0.4294074591
0.4851048742
0.4896018842
0.4525044250
0.3406567483
0.6421630037
Source
暴力。dp[d][i]表示走了d步时走到i的概率。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<limits.h>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long LL;
int t,n,m,d;
double dp[10000+10][55];
vector<int>v[55];
void solve(int x)
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
dp[0][i]=1.0/n;
for(int i=0;i<d;i++)
{
for(int j=1;j<=n;j++)
{
if(j==x) continue;
for(int k=0;k<v[j].size();k++)
dp[i+1][v[j][k]]+=dp[i][j]*1.0/v[j].size();
}
}
double ans=0.0;
for(int i=1;i<=n;i++)
{
if(i!=x)
ans+=dp[d][i];
}
printf("%.5f\n",ans);
}
int main()
{
int x,y;
scanf("%d",&t);
while(t--)
{
for(int i=0;i<55;i++)
v[i].clear();
scanf("%d%d%d",&n,&m,&d);
for(int i=0;i<m;i++)
{
scanf("%d%d",&x,&y);
v[x].push_back(y);
v[y].push_back(x);
}
for(int i=1;i<=n;i++)
solve(i);
}
return 0;
}
另附别人丧心病狂的头文件,我也是醉了




HDU 5001 Walk
标签:des style blog http color io os ar for
原文地址:http://blog.csdn.net/u013582254/article/details/39259117