码迷,mamicode.com
首页 > 其他好文 > 详细

Asteroids(二分匹配_最小点覆盖)

时间:2014-09-14 14:08:57      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:算法

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

题意:在一个N*N的矩阵中 有K个障碍物,你有一个武器 每次使用 可以清除某行 或 某列 的障碍物,但是这种武器非常昂贵,所以你要尽可能少的使用;输出 最少使用多少次武器 可以清除所有的障碍物;
思路:裸的二分匹配匈牙利算法。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int map[510][510];
int vis[510];
int link[510];
int n;
int dfs(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(link[i]==0||dfs(link[i]))

            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int m,i;
    int u,v;
    int sum=0;
    memset(map,0,sizeof(map));
    memset(link,0, sizeof(link));
    scanf("%d %d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%d %d",&u,&v);
            map[u][v]=1;
        }
        for(i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
            {
                sum++;
            }
        }
        printf("%d\n",sum);
    return 0;
}



Asteroids(二分匹配_最小点覆盖)

标签:算法

原文地址:http://blog.csdn.net/u013486414/article/details/39268845

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!