码迷,mamicode.com
首页 > 其他好文 > 详细

poj-1195-Mobile Phones

时间:2017-11-18 21:58:36      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:orm   ogr   matrix   ble   lang   return   arc   分享图片   lin   

poj-1195-Mobile Phones 

 

 

Mobile phones
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 20907   Accepted: 9662

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 
技术分享图片

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

 

 

17857925   1195 Accepted 4500K 1079MS G++ 1287B 2017-11-18 20:33:00

 

二维树状数组。

 

 

/// poj -1195 
#include <cstdio> 
#include <cstring> 
const int MAXN = 1025; 

int s, mp[MAXN][MAXN]; 

inline int lowbit(int x){
	return x & (-x); 
}

long long Compute(int x1, int y1, int x2, int y2){
	long long  ans, ans1 = 0, ans2 = 0, ans3 = 0, ans4 = 0; 
	for(int i=x1-1; i>0; i-=lowbit(i)){
		for(int j=y1-1; j>0; j-=lowbit(j)){
			ans1 += mp[i][j]; 
		}
	}
	for(int i=x2; i>0; i-=lowbit(i)){
		for(int j=y2; j>0; j-=lowbit(j)){
			ans2 += mp[i][j]; 
		}
	}
	for(int i=x2; i>0; i-=lowbit(i)){
		for(int j=y1-1; j>0; j-=lowbit(j)){
			ans3 += mp[i][j]; 
		}
	}
	for(int i=x1-1; i>0; i-=lowbit(i)){
		for(int j=y2; j>0; j-=lowbit(j)){
			ans4 += mp[i][j]; 
		}
	}
	ans = ans1 + ans2 - ans4 - ans3; 
	return ans; 
}

void Add(int x, int y, const int val){
	for(int i=x; i<=s; i+=lowbit(i)){
		for(int j=y; j<=s; j+=lowbit(j)){
			mp[i][j] += val; 
		}
	}
}

int main(){
	freopen("in.txt", "r", stdin); 

	int n, x1, y1, x2, y2, val; 
	long long ans; 
	while(scanf("%d", &n ) != EOF){
		if(n >= 3){
			break; 
		}else if(n == 0){
			scanf("%d", &s); 
			memset(mp, 0, sizeof(mp)); 
		}else if(n == 1){
			scanf("%d %d %d", &x1, &y1, &val); 
			Add(x1 + 1, y1 + 1, val);  
		}else{
			scanf("%d %d %d %d", &x1,  &y1, &x2, &y2 ); 
			ans = Compute( x1 + 1, y1 + 1, x2 + 1, y2 + 1 ); 
			printf("%lld\n", ans );
		}
	} 
	return 0; 
}

  

 

poj-1195-Mobile Phones

标签:orm   ogr   matrix   ble   lang   return   arc   分享图片   lin   

原文地址:http://www.cnblogs.com/zhang-yd/p/7857872.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!