码迷,mamicode.com
首页 > 其他好文 > 详细

[最小表示] poj 1509 Glass Beads

时间:2014-05-11 13:47:01      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   tar   

题目链接:

http://poj.org/problem?id=1509

Glass Beads
Time Limit: 3000MS   Memory Limit: 10000K
Total Submissions: 2311   Accepted: 1343

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace. 

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads. 

The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion. 

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题目意思:

给一个字符串,求循环字符串中字典序最小的那个起始位置。

解题思路:

裸的最小表示。

注意当i,j改变后且i==j时,要i++或j++不然就是一样的了,因为是一个串。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 210000

char save[Maxn];

int cal()
{
    int n=strlen(save+1);

    int i=1,j=2;
    for(int i=n+1;i<=2*n;i++)
        save[i]=save[i-n];
    //save[2*n+1]=save[1];

    while(i<=n&&j<=n)
    {
        int k=0;

        while(save[i+k]==save[j+k]&&k<n)
            k++;
        if(k>=n)
            break;
        if(save[i+k]>save[j+k])
        {
             i=i+k+1;
             if(i==j) //要手动改下
                i++;
        }
        else
        {
            j=j+k+1;
            if(i==j)
                i++;
        }

    }
    return min(i,j);
}
int main()
{
   //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   int t;

   scanf("%d",&t);
   while(t--)
   {
       scanf("%s",save+1);
       printf("%d\n",cal());
   }
   return 0;
}




[最小表示] poj 1509 Glass Beads,布布扣,bubuko.com

[最小表示] poj 1509 Glass Beads

标签:des   style   blog   class   code   tar   

原文地址:http://blog.csdn.net/cc_again/article/details/25501629

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!