码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3608 两凸包最近距离 旋转卡壳

时间:2014-05-11 13:01:55      阅读:454      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   ext   

Bridge Across Islands
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8071   Accepted: 2364   Special Judge

Description

Thousands of thousands years ago there was a small kingdom located in the middle of the Pacific Ocean. The territory of the kingdom consists two separated islands. Due to the impact of the ocean current, the shapes of both the islands became convex polygons. The king of the kingdom wanted to establish a bridge to connect the two islands. To minimize the cost, the king asked you, the bishop, to find the minimal distance between the boundaries of the two islands.

bubuko.com,布布扣

Input

The input consists of several test cases.
Each test case begins with two integers N, M. (3 ≤ N, M ≤ 10000)
Each of the next N lines contains a pair of coordinates, which describes the position of a vertex in one convex polygon.
Each of the next M lines contains a pair of coordinates, which describes the position of a vertex in the other convex polygon.
A line with N = M = 0 indicates the end of input.
The coordinates are within the range [-10000, 10000].

Output

For each test case output the minimal distance. An error within 0.001 is acceptable.

Sample Input

4 4
0.00000 0.00000
0.00000 1.00000
1.00000 1.00000
1.00000 0.00000
2.00000 0.00000
2.00000 1.00000
3.00000 1.00000
3.00000 0.00000
0 0

Sample Output

1.00000


经典题目

代码:

/* ***********************************************
Author :_rabbit
Created Time :2014/5/10 16:26:51
File Name :20.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-5
#define pi acos(-1.0)
typedef long long ll;
int dcmp(double x){
	if(fabs(x)<eps)return 0;
	return x>0?1:-1;
}
struct Point{
	double x,y;
	Point(double _x=0,double _y=0){
		x=_x;y=_y;
	}
};
Point operator + (const Point &a,const Point &b){  
    return Point(a.x+b.x,a.y+b.y);  
}  
Point operator - (const Point &a,const Point &b){  
    return Point(a.x-b.x,a.y-b.y);  
}  
Point operator * (const Point &a,const double &p){  
    return Point(a.x*p,a.y*p);  
}  
Point operator / (const Point &a,const double &p){  
    return Point(a.x/p,a.y/p);  
}  
bool operator < (const Point &a,const Point &b){  
    return a.x<b.x||(a.x==b.x&&a.y<b.y);  
}  
bool operator == (const Point &a,const Point &b){  
    return dcmp(a.x-b.x)==0&&dcmp(a.y-b.y)==0;  
}  
double Dot(Point  a,Point b){  
    return a.x*b.x+a.y*b.y;  
}  
double Length(Point a){  
    return sqrt(Dot(a,a));  
}  
double Angle(Point a,Point b){  
    return acos(Dot(a,b)/Length(a)/Length(b));  
}  
double angle(Point a){  
    return atan2(a.y,a.x);  
}  
double Cross(Point a,Point b){  
    return a.x*b.y-a.y*b.x;  
}  
Point vecunit(Point a){  
    return a/Length(a);  
}  
Point Normal(Point a){  
    return Point(-a.y,a.x)/Length(a);  
}  
Point Rotate(Point a,double rad){  
    return Point(a.x*cos(rad)-a.y*sin(rad),a.x*sin(rad)+a.y*cos(rad));  
}  
double Area2(Point a,Point b,Point c){  
    return Length(Cross(b-a,c-a));  
}  
double DistanceToSegment(Point p, Point a, Point b)  {  
    if(a == b) return Length(p-a);  
    Point v1 = b-a, v2 = p-a, v3 = p-b;  
    if(dcmp(Dot(v1, v2)) < 0) return Length(v2);  
    else if(dcmp(Dot(v1, v3)) > 0) return Length(v3);  
    else return fabs(Cross(v1, v2)) / Length(v1);  
}  
double dis_pair_seg(Point p1, Point p2, Point p3, Point p4)  {  
    return min(min(DistanceToSegment(p1, p3, p4), DistanceToSegment(p2, p3, p4)),  
     min(DistanceToSegment(p3, p1, p2), DistanceToSegment(p4, p1, p2)));  
}  
vector<Point> CH(vector<Point> p){
	sort(p.begin(),p.end());
	p.erase(unique(p.begin(),p.end()),p.end());
	int n=p.size();
	int m=0;
	vector<Point> ch(n+1);
	for(int i=0;i<n;i++){
		while(m>1&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-1])<=0)m--;
		ch[m++]=p[i];
	}
	int k=m;
	for(int i=n-2;i>=0;i--){
		while(m>k&&Cross(ch[m-1]-ch[m-2],p[i]-ch[m-2])<=0)m--;
		ch[m++]=p[i];
	}
	if(n>1)m--;
	ch.resize(m);
	return ch;
}
double RC_Distance(vector<Point> ch1,vector<Point> ch2)  
{  
    int q=0, p=0,n=ch1.size(),m=ch2.size();
    for(int i=0;i<n;i++) if(ch1[i].y-ch1[p].y < -eps) p=i;  
    for(int i=0;i<m;i++)if(ch2[i].y-ch2[q].y > eps) q=i;  
    ch1.push_back(ch1[0]);ch2.push_back(ch2[0]); 
  
    double tmp, ans=1e100;  
    for(int i=0;i<n;i++) 
    {  
        while((tmp = Cross(ch1[p+1]-ch1[p], ch2[q+1]-ch1[p]) - Cross(ch1[p+1]-ch1[p], ch2[q]- ch1[p])) > eps)  
            q=(q+1)%m;  
        if(tmp < -eps) ans = min(ans,DistanceToSegment(ch2[q],ch1[p],ch1[p+1]));  
        else ans = min(ans,dis_pair_seg(ch1[p],ch1[p+1],ch2[q],ch2[q+1]));  
        p=(p+1)%n;  
    }  
    return ans;  
}  

int main()
{
     //freopen("data.in","r",stdin);
     //freopen("data.out","w",stdout);
     int n,m;
	 while(cin>>n>>m){
		 if(n==0&&m==0)break;
		 vector<Point> ch1,ch2;
		 Point p;
		 while(n--)scanf("%lf%lf",&p.x,&p.y),ch1.push_back(p);
		 while(m--)scanf("%lf%lf",&p.x,&p.y),ch2.push_back(p);
		 ch1=CH(ch1);ch2=CH(ch2);
		 printf("%.5lf\n",RC_Distance(ch1,ch2));
	 }
     return 0;
}


POJ 3608 两凸包最近距离 旋转卡壳,布布扣,bubuko.com

POJ 3608 两凸包最近距离 旋转卡壳

标签:des   style   blog   class   code   ext   

原文地址:http://blog.csdn.net/xianxingwuguan1/article/details/25496525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!