标签:des style http color io os ar strong for
Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:
● ai ∈ [0,n]
● ai ≠ aj( i ≠ j )
For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):
t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)
(sequence B should also satisfy the rules described above)
Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
Input
There are multiple test cases. Please process till EOF.
For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0
≤ i ≤ n - 1). Don’t ouput any spaces after bn.
Sample Input
Sample Output
Source
思路:从最大的一个数开始找能配对使他们的异或值最大的一个数即可。幸亏比赛的时候不是我敲,因为longlong WA 了好几发。
#include <stdio.h>
int num[100005],d[100005];
int main()
{
int n,i,j,t;
long long ans;
while(~scanf("%d",&n))
{
for(i=0;i<=n;i++) d[i]=-1;
for(i=0;i<=n;i++) scanf("%d",&num[i]);
ans=0;
for(i=n;i>=0;i--)
{
if(d[i]==-1)
{
t=0;
for(j=0;;j++)
{
if(!(i&(1<<j))) t+=1<<j;
if(t>=i) break;
}
t-=(1<<j);
ans+=(i^t)+(i^t);
d[i]=t;
d[t]=i;
}
}
printf("%I64d\n",ans);
for(i=0;i<n;i++) printf("%d ",d[num[i]]);
printf("%d\n",d[num[n]]);
}
}
HDU-5014-Number Sequence
标签:des style http color io os ar strong for
原文地址:http://blog.csdn.net/faithdmc/article/details/39278381