码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5011 Game

时间:2014-09-15 01:09:08      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   java   ar   strong   


和NIM博弈是一模一样的

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 148    Accepted Submission(s): 116


Problem Description
Here is a game for two players. The rule of the game is described below: 

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing) 

● If after a player‘s turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 

Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads in the i-th pile.
 

Output
For each test case, if the first player can win the game, ouput "Win" and if he can‘t, ouput "Lose"
 

Sample Input
1 1 2 1 1 3 1 2 3
 

Sample Output
Win Lose Lose
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int x,ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            ans=ans^x;
        }
        if(ans==0)
            puts("Lose");
        else puts("Win");
    }
    return 0;
}



HDOJ 5011 Game

标签:des   style   http   color   io   os   java   ar   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/39276703

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!