码迷,mamicode.com
首页 > 其他好文 > 详细

1075. PAT Judge (25)

时间:2017-11-27 23:43:20      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:http   nta   form   res   blog   status   pat   seve   ios   

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id‘s are 5-digit numbers from 00001 to N, and the problem id‘s are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id‘s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
struct Node{
	vector<int>problem;
	int total_score;
	int answer_num;
	int id;
	int rank;
	int flag;
}; 
vector<Node>user;
vector<int>score;
bool cmp(Node a,Node b){
	if(a.total_score > b.total_score){
		return true;
	}else if(a.total_score == b.total_score){
		if(a.answer_num > b.answer_num){
			return true;
		}else if(a.answer_num == b.answer_num){
			if(a.id < b.id){
				return true;
			}else {
				return false;
			}
		}else {
			return false;
		}
	}else {
		return false;
	}
}
int main(){
	int n,k,m;
	scanf("%d%d%d",&n,&k,&m);
	score.resize(k);
	user.resize(n);
	int i,j;
	for(i=0;i<k;i++){
		scanf("%d",&score[i]);
	}
	for(i=0;i<n;i++){
		user[i].problem.resize(k);
		for(j=0;j<k;j++){
			user[i].problem[j]=-1;
		}
		user[i].answer_num=0;
		user[i].total_score=0;
		user[i].flag=0;
	}
	int user_id,problem_id,grade;
	for(i=0;i<m;i++){
		scanf("%d%d%d",&user_id,&problem_id,&grade);
		user_id--;
		problem_id--;
		user[user_id].id=user_id;
		int tmp_grade=user[user_id].problem[problem_id];
		if(tmp_grade<grade){
			if(tmp_grade != score[problem_id] && grade == score[problem_id]){
				user[user_id].answer_num+=1;
			}
			user[user_id].problem[problem_id]=grade;
			user[user_id].flag=1;
		}else if(grade == -1){
			user[user_id].problem[problem_id]=0;
		}
	}
	for(i=0;i<n;i++){
		int sum=0;
		for(j=0;j<k;j++){
			if(user[i].problem[j]!=-1){
				sum+=user[i].problem[j];
			}
		}
		user[i].total_score=sum;
	}
	sort(user.begin(),user.end(),cmp);
	int rank=1;
	grade = user[0].total_score;
	for(i=0;i<n;i++){
		if(user[i].total_score == grade){
			user[i].rank=rank;
		}else {
			rank=i+1;
			user[i].rank=rank;
			grade=user[i].total_score;
		}
	}
	for(i=0;i<n;i++){
		if(user[i].flag==0)break;
		printf("%d %05d",user[i].rank,user[i].id+1);
		printf(" %d",user[i].total_score);
		for(j=0;j<k;j++){
			if(user[i].problem[j]==-1){
				printf(" -");
			}else{
				printf(" %d",user[i].problem[j]);
			}
		}
		printf("\n");
	}
	return 0;
}

  

 技术分享图片

1075. PAT Judge (25)

标签:http   nta   form   res   blog   status   pat   seve   ios   

原文地址:http://www.cnblogs.com/grglym/p/7906258.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!