码迷,mamicode.com
首页 > 其他好文 > 详细

HihoCoder1338 A Game(记忆化搜索)

时间:2017-12-02 22:07:36      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:output   std   remove   ios   length   str   pac   play   内存   

时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述

Little Hi and Little Ho are playing a game. There is an integer array in front of them. They take turns (Little Ho goes first) to select a number from either the beginning or the end of the array. The number will be added to the selecter‘s score and then be removed from the array.

Given the array what is the maximum score Little Ho can get? Note that Little Hi is smart and he always uses the optimal strategy. 

输入

The first line contains an integer N denoting the length of the array. (1 ≤ N ≤ 1000)

The second line contains N integers A1A2, ... AN, denoting the array. (-1000 ≤ Ai ≤ 1000)

输出

Output the maximum score Little Ho can get.

样例输入
4
-1 0 100 2
样例输出
99

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
using namespace std;
int a[1010],dp[1010][1010];
int getdp(int L,int R)
{
    if(dp[L][R]) return dp[L][R];
    if(L == R) return a[L];
    if(L==R-1) dp[L][R]=max(a[L],a[R]);
    else dp[L][R]=max(a[L]+min(getdp(L+2,R),getdp(L+1,R-1)),a[R]+min(getdp(L,R-2),getdp(L+1,R-1)));
    return dp[L][R];
}
int main()
{
    int n,i;
    scanf("%d",&n);
    for(i = 1;i <= n;i ++)  scanf("%d",&a[i]);
    printf("%d\n",getdp(1,n));
    return 0;
}

 

HihoCoder1338 A Game(记忆化搜索)

标签:output   std   remove   ios   length   str   pac   play   内存   

原文地址:http://www.cnblogs.com/hua-dong/p/7955603.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!