码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1492 The number of divisors(约数) about Humble Numbers(数学题)

时间:2014-09-15 19:32:29      阅读:190      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1492


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
4 12 0
 

Sample Output
3 6


代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    __int64 n;
    __int64 a[4] = {2,3,5,7}, b[4];
    while(scanf("%I64d",&n) && n)
    {
        memset(b,0,sizeof(b));
        for(int i = 0; i < 4; i++)
        {
            while(n%a[i] == 0)
            {
                b[i]++;
                n/=a[i];
            }
        }
        __int64 ans = (b[0]+1)*(b[1]+1)*(b[2]+1)*(b[3]+1);
        printf("%I64d\n",ans);
    }
    return 0;
}


HDU 1492 The number of divisors(约数) about Humble Numbers(数学题)

标签:hdu   数学   

原文地址:http://blog.csdn.net/u012860063/article/details/39296257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!