码迷,mamicode.com
首页 > 其他好文 > 详细

1029. Median (25)

时间:2017-12-04 00:01:53      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:ring   ted   set   first   sam   size   ber   form   代码   

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.

Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13


排序
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
#include <algorithm>
using namespace std;

long long s[2000000];
int main()
{
    int a,b;
    scanf("%d",&a);
    for(int i = 0;i < a;i ++)
    {
        scanf("%lld",&s[i]);
    }
    scanf("%d",&b);
    b += a;
    for(int i = a;i < b;i ++)
    {
        scanf("%lld",&s[i]);
    }
    sort(s,s+b);
    printf("%lld",s[(b-1)/2]);
}

 

1029. Median (25)

标签:ring   ted   set   first   sam   size   ber   form   代码   

原文地址:http://www.cnblogs.com/8023spz/p/7967799.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!