码迷,mamicode.com
首页 > 其他好文 > 详细

1076. Forwards on Weibo (30)

时间:2017-12-04 17:39:09      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:scanf   where   enc   printf   push   lines   nes   iostream   nta   

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID‘s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

解题思路:利用vector存储user间的临接表,利用queue来广度搜索。

#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cstring>
using namespace std;
vector<int>vt[1005];
bool flag[1005];
int n,level;
int MaxForward(int val){
	memset(flag,false,sizeof(flag));
	queue<int>q;
	q.push(val);
	flag[val]=true;
	int sum=1;
	int cntLevel=0;
	int start=0;
	int end=1;
	while(!q.empty()){
		val=q.front();
		q.pop();
		start++;
		int size=vt[val].size();
		for(int i=0;i<size;i++){
			if(flag[vt[val][i]]==false){
				q.push(vt[val][i]);
				flag[vt[val][i]]=true;
				sum++;
			}
		}
		if(start==end){//计算层数 
			end=sum;
			cntLevel++;
		}
		if(level==cntLevel){
			return sum-1;
		}
	}
	return sum-1;
}
int main(){
	scanf("%d%d",&n,&level);
	int tmp,val;
	for(int i=1;i<=n;i++){
		scanf("%d",&tmp);
		for(int j=0;j<tmp;j++){
			scanf("%d",&val);
			vt[val].push_back(i);
		}
	}
	int k;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d",&val);
		val=MaxForward(val);
		printf("%d\n",val);
	}
	return 0;
}

  




1076. Forwards on Weibo (30)

标签:scanf   where   enc   printf   push   lines   nes   iostream   nta   

原文地址:http://www.cnblogs.com/grglym/p/7977800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!