码迷,mamicode.com
首页 > 其他好文 > 详细

poj-1469-COURSES

时间:2017-12-04 23:34:11      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:continue   ext   oss   form   cst   positive   pos   number   rate   

poj-1469-COURSES

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24542   Accepted: 9557

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

 

 

17919736   1469 Accepted 512K 407MS G++ 906B 2017-12-04 22:09:08

 

 

经典的匈牙利算法解决方法。

 

利用二分图,找到每一个学生和course之间的match,使用匈牙利算法。

 

 

// poj-1469 

#include <cstdio> 
#include <cstring> 
const int MAXN = 300 + 10; 

int P, N, num[MAXN], course[MAXN][MAXN]; 

int match[MAXN], vis[MAXN]; 

bool dfs(int x){
	for(int i=1; i<=num[x]; ++i){
		int y = course[x][i]; 
		if( vis[y] == 0 ){
			vis[y] = 1;
			if(match[y] < 0 || dfs(match[y])){
				match[y] = x; 
				return true; 
			}
		}
	}
	return false; 
}

int main(){
	freopen("in.txt", "r", stdin); 

	int test_num; 
	scanf("%d", &test_num); 

	int ans; 
	while(test_num--){
		scanf("%d %d", &P, &N); 
		for(int i=1; i<=P; ++i){
			scanf("%d", &num[i]); 
			for(int j=1; j<=num[i]; ++j){
				scanf("%d", &course[i][j]); 
			} 
		}

		if(P > N){
			printf("NO\n");
			continue; 
		}

		ans = 0; 
		memset(match, -1, sizeof(match));  

		for(int i=1; i<=P; ++i){
			memset(vis, 0, sizeof(vis));  
			if( dfs(i) ){
				++ans; 
			}
		} 

		if(ans >= P){ 
			printf("YES\n");
		}else{
			printf("NO\n");
		} 
	}
	return 0; 
}

  

 

poj-1469-COURSES

标签:continue   ext   oss   form   cst   positive   pos   number   rate   

原文地址:http://www.cnblogs.com/zhang-yd/p/7979274.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!