标签:des style blog color io os java ar strong
A Walk Through the Forest
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5809 Accepted Submission(s): 2147
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A
nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from
B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections
N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any
direction he chooses. There is at most one path between any pair of intersections.
Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
Sample Input
5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0
Sample Output
题意:求一共有几条最短路,先用dijkstra算法求出每个点到目标点的最短距离,然后,从源点开始深搜求dis[v]<dis[u]的数目。用到记忆化搜索。
#include"stdio.h"
#include"string.h"
#include"math.h"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 1005
const int inf=0x7fffffff;
int mark[N],dis[N];
int g[N][N],n;
void dijkstra(int s)
{
int i,u,min;
memset(mark,0,sizeof(mark));
for(i=0;i<=n;i++)
dis[i]=g[s][i];
dis[s]=0;
mark[s]=1;
while(1)
{
min=inf;
u=s;
for(i=1;i<=n;i++)
{
if(min>dis[i]&&!mark[i])
{
min=dis[i];
u=i;
}
}
if(u==s)
break;
mark[u]=1;
for(i=1;i<=n;i++)
{
if(g[u][i]!=inf&&dis[i]>dis[u]+g[u][i])
dis[i]=dis[u]+g[u][i];
}
}
}
int bfs(int u)
{
if(mark[u])
return mark[u];
int i,cnt=0;
for(i=1;i<=n;i++)
{
if(u==i||g[u][i]==inf)
continue;
if(dis[u]>dis[i])
{
cnt+=bfs(i);
}
}
return mark[u]=cnt;
}
int main()
{
int i,j,u,v,d,m;
while(scanf("%d",&n),n)
{
scanf("%d",&m);
for(i=0;i<=n;i++)
{
for(j=0;j<=n;j++)
g[i][j]=(i==j?0:inf);
}
for(i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&d);
g[u][v]=g[v][u]=d;
}
dijkstra(2);
memset(mark,0,sizeof(mark));
mark[2]=1;
int ans=bfs(1);
printf("%d\n",ans);
}
return 0;
}
hdu 1142 A Walk Through the Forest (最短路+dfs )
标签:des style blog color io os java ar strong
原文地址:http://blog.csdn.net/u011721440/article/details/39299679