码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1042-N!(大数类)

时间:2014-09-15 22:52:59      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:acm   java   biginteger   大数类   

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54761    Accepted Submission(s): 15578


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
1 2 3
 

Sample Output
1 2 6
求10000以内的阶乘。java+暴力。。。
import java.io.*;
import java.util.*;
import java.math.*;
public class Main {
       public static void main(String[] args){
    	   Scanner in=new Scanner(System.in);
    	   int n,i;BigInteger ans,t;
    	   while(in.hasNext()){
    		   n=in.nextInt();
    		   ans=new BigInteger("1");
    		   for(i=1;i<=n;i++){
    			   t=new BigInteger(Integer.toString(i));
    			   ans=ans.multiply(t);
    		   }
    		   System.out.println(ans);
    	   }
       }
}

HDU 1042-N!(大数类)

标签:acm   java   biginteger   大数类   

原文地址:http://blog.csdn.net/qq_16255321/article/details/39299583

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!