码迷,mamicode.com
首页 > 其他好文 > 详细

kuangbin专题五:C - How Many Tables HDU - 1213

时间:2017-12-07 21:14:28      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:sizeof   script   span   string   return   union   color   hat   init   

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4
题意:A 认识 B , B 认识 C , 则 A B C 可以坐在一张桌子上 , 所有相互认识的人组成一个集合 一个集合的人坐一张桌子
   问 需要准备多少张桌子 (有多少个集合)。
思路:并查集 模板题目。
技术分享图片
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std ; 
#define maxn 5000
int n , m ; 
int num1 , num2 ; 
int t ; 
int father[maxn] ; 
bool visit[maxn] ; 

void init(){
    for(int i=1 ; i<=n ; i++){
        father[i] = i ; 
    }
    return;
}

int find(int x){
    if(x!=father[x]){
        father[x] = find(father[x]) ; 
    }
    return father[x] ; 
}

void Union_set(int x , int y){
    int rootx = find(x) ; 
    int rooty = find(y) ; 
     
    if(rootx != rooty){
        father[rooty] = rootx ; 
        
    }
    return;
}

int check(){
    memset(visit , false , sizeof(visit)) ; 

    int result = 0 ; 
    for(int i=1 ; i<=n ; i++){
        visit[find(i)] = true ; 
    }
    for(int i=1 ; i<=n ; i++){
        if(visit[i]){
            
            result ++ ; 
        }
    }
    return result ; 
}

int main(){

    scanf("%d" , &t) ; 
    while(t--){
        
        scanf("%d %d" , &n , &m) ; 
        init() ;
        for(int i=1 ; i<=m ; i++){
            scanf("%d %d" , &num1 , &num2) ; 
            Union_set(num1 , num2) ; 
        }

        int result = check() ; 
      
        printf("%d\n" , result) ; 
    }
    return 0 ; 
}
View Code

 

kuangbin专题五:C - How Many Tables HDU - 1213

标签:sizeof   script   span   string   return   union   color   hat   init   

原文地址:http://www.cnblogs.com/yi-ye-zhi-qiu/p/8000616.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!