码迷,mamicode.com
首页 > 其他好文 > 详细

1036. Boys vs Girls (25)

时间:2017-12-12 23:56:39      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:mes   代码   more   inf   else   positive   for   tin   end   

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student‘s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

 

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA


代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define Max 105
using namespace std;
struct stu
{
    string name,id;
    char gender;
    int grade;
}s[10000],a,b;
int main()
{
    int n;
    cin>>n;
    a.grade = -1;
    b.grade = 101;
    for(int i = 0;i < n;i ++)
    {
        cin>>s[i].name>>s[i].gender>>s[i].id>>s[i].grade;
        if(s[i].gender == F && s[i].grade > a.grade)a = s[i];
        if(s[i].gender == M && s[i].grade < b.grade)b = s[i];
    }
    if(a.grade != -1)cout<<a.name<< <<a.id<<endl;
    else cout<<"Absent"<<endl;
    if(b.grade != 101)cout<<b.name<< <<b.id<<endl;
    else cout<<"Absent"<<endl;
    if(a.grade != -1 && b.grade != 101)cout<<a.grade - b.grade<<endl;
    else cout<<"NA"<<endl;
}

 

1036. Boys vs Girls (25)

标签:mes   代码   more   inf   else   positive   for   tin   end   

原文地址:http://www.cnblogs.com/8023spz/p/8030050.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!