标签:des style blog color io os java ar strong
Number Sequence
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 697 Accepted Submission(s): 332
Special Judge
Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:
● ai ∈ [0,n]
● ai ≠ aj( i ≠ j )
For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):
t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)
(sequence B should also satisfy the rules described above)
Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
Input
There are multiple test cases. Please process till EOF.
For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0
≤ i ≤ n - 1). Don’t ouput any spaces after bn.
Sample Input
Sample Output
随意写一个二进制数x=100100,总能找到唯一的一个数与它异或得到111111;对于每个N位二进制数,每次总使它与一个数异或得到11...11(N个1)。即为最优解,且唯一。
#include"stdio.h"
#include"math.h"
#include"string.h"
#define LL __int64
#define N 100005
int a[N],p[N],b[N];
int fun(int x)
{
int t=1;
while(t<=x)
t*=2;
return x^(t-1);
}
int main()
{
int i,n;
while(scanf("%d",&n)!=-1)
{
for(i=0;i<=n;i++)
scanf("%d",&a[i]);
memset(p,-1,sizeof(p));
for(i=n;i>=0;i--)
{
if(p[i]!=-1)
continue;
int t=fun(i);
p[t]=i;
p[i]=t;
}
LL s=0;
for(i=0;i<=n;i++)
{
b[i]=p[a[i]];
s+=a[i]^b[i];
}
printf("%I64d\n",s);
for(i=0;i<n;i++)
printf("%d ",b[i]);
printf("%d\n",b[n]);
}
return 0;
}
hdu 5014 Number Sequence (贪心)
标签:des style blog color io os java ar strong
原文地址:http://blog.csdn.net/u011721440/article/details/39320937