码迷,mamicode.com
首页 > 其他好文 > 详细

hdu_4336_Card Collector

时间:2017-12-19 19:43:37      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:ret   div   and   smart   printf   main   for   cto   memset   

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

InputThe first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.OutputOutput one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.Sample Input

1
0.1
2
0.1 0.4

Sample Output

10.000
10.500


这道题一开始怎么都没想懂,其实就是一个容斥,分别计算收集齐1-n套卡的概率。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL long long
#define maxn 70
#define N 25
double e[N];
double p[N];
int n;

int main()
{
	LL a,b,i;

	//scanf("%ld",&T);
	while(~scanf("%d",&n))
	{
	    double ans=0;
	    double res=1.0;
	    int flag=0;
	    double tmp;
	    memset(p,0,sizeof(p));
	    for(int i=0;i<n;i++)
        {
            scanf("%lf",&p[i]);
            res-=p[i];
        }
        for(int i=1;i<(1<<n);i++)
        {
            tmp=0,flag=0;
            for(int j=0;j<n;j++)
                if(i&((1<<j)))
                    flag++,tmp+=p[j];
            if(flag&1)
                ans+=1.0/tmp;
            else
                ans-=1.0/tmp;
        }
        printf("%.5lf\n",ans);
	}
	return 0;
}

  

hdu_4336_Card Collector

标签:ret   div   and   smart   printf   main   for   cto   memset   

原文地址:http://www.cnblogs.com/ygtzds/p/8066011.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!