码迷,mamicode.com
首页 > 其他好文 > 详细

1051. Pop Sequence (25)

时间:2017-12-23 23:01:46      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:blog   problem   rom   print   break   sed   span   sequence   bsp   

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO


跟有一道题叫做列车调度的经典栈题挺像的,把1到n依次放入栈,每次把栈顶元素跟输入序列的元素进行判断如果相等,栈扔出一个元素,同时输入的序列的坐标也后移一个,依次进行,如果栈的大小等于他的容量了然后并没有匹配的元素,直接是不满足的。

代码:
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <map>
#include <stack>
using namespace std;
int m,n,k,s[1000],st[1000];
bool check()
{
    stack<int> p;
    int i = 1,j = 0;
    while(i <= n)
    {
        p.push(i ++);
        while(!p.empty() && p.top() == s[j])
        {
            j ++;
            p.pop();
        }
        if(p.size() == m)break;
    }
    if(p.empty() && j == n)return true;
    return false;
}
int main()
{
    cin>>m>>n>>k;
    for(int i = 0;i < k;i ++)
    {
        for(int j = 0;j < n;j ++)
        {
            cin>>s[j];
        }
        cout<<(check() == true ? "YES" : "NO")<<endl;
    }
}

 

1051. Pop Sequence (25)

标签:blog   problem   rom   print   break   sed   span   sequence   bsp   

原文地址:http://www.cnblogs.com/8023spz/p/8094484.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!