码迷,mamicode.com
首页 > 其他好文 > 详细

1052. Linked List Sorting (25)

时间:2017-12-25 23:27:11      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:strong   algorithm   pre   from   where   sts   format   incr   blog   

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

根据首地址,把链表过一遍,按顺序存一下地址,去除无关结点,然后根据地址排一下序。快排。
代码:
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
struct link
{
    int add,data,next;
}s[100000],*p[100000];
int no = 0;
bool cmp(link *a,link *b)
{
    return a -> data < b -> data;
}
int main()
{
    int n,first_address,j,c = 0;
    scanf("%d%d",&n,&first_address);
    int address,data,next;
    for(int i = 0;i < n;i ++)
    {
        scanf("%d%d%d",&address,&data,&next);
        s[address].add = address;
        s[address].data = data;
        s[address].next = next;
    }
    for(int i = first_address;i != -1;i = s[i].next)
    {
        p[no ++] = &s[i];
    }
    sort(p,p+no,cmp);
    if(no)first_address = p[0] -> add;
    if(first_address != -1)printf("%d %05d\n",no,first_address);//可能有空链表 首地址是-1,估计最后一个测试点就是这样
    else printf("%d %d\n",no,first_address);
    for(int i = 0;i < no - 1;i ++)
    {
        printf("%05d %d %05d\n",p[i] -> add,p[i] -> data,p[i] -> next = p[i + 1] -> add);
    }
    if(no)printf("%05d %d %d",p[no - 1] -> add,p[no - 1] -> data,p[no - 1] -> next = -1);
}

 

1052. Linked List Sorting (25)

标签:strong   algorithm   pre   from   where   sts   format   incr   blog   

原文地址:https://www.cnblogs.com/8023spz/p/8111493.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!