码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1054. 求平均值

时间:2017-12-28 14:02:43      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:main   pac   tde   无法   空格   格式   dex   aaa   amp   

PAT 1054. 求平均值

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析

我用的是抛出异常,下面也附上另一种方式

代码如下

#include<iostream>
#include<stdexcept>
using namespace std;
int main(){
    int N,cnt=0;
    double sum=0.0;
    cin>>N; string s="";
    char ch[50];
    for(int i=0;i<N;i++){
    cin>>s;
    try{
        sprintf(ch,"%.2lf",stod(s));
        for(int j=0;j<s.size();j++)
        if(s[j]!=ch[j]) throw invalid_argument("");
        if(stod(s)<-1000||stod(s)>1000) throw invalid_argument("");
        else {sum+=stod(s);cnt++;}
    }catch(invalid_argument err){
         cout<<"ERROR: "<<s<<" is not a legal number"<<endl;
    }   
    }
     if(cnt == 1) {
        printf("The average of 1 number is %.2lf", sum);
    } else if(cnt > 1) {
        printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
    } else {
        printf("The average of 0 numbers is Undefined");
    }
}

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
int main() {
    int n, cnt = 0;
    char a[50], b[50];
    double temp, sum = 0.0;
    cin >> n;
    for(int i = 0; i < n; i++) {
        scanf("%s", a);
        sscanf(a, "%lf", &temp);
        sprintf(b, "%.2lf",temp);
        int flag = 0;
        for(int j = 0; j < strlen(a); j++) {
            if(a[j] != b[j]) flag = 1;
        }
        if(flag || temp < -1000 || temp > 1000) {
            printf("ERROR: %s is not a legal number\n", a);
            continue;
        } else {
            sum += temp;
            cnt++;
        }
    }
    if(cnt == 1) {
        printf("The average of 1 number is %.2lf", sum);
    } else if(cnt > 1) {
        printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
    } else {
        printf("The average of 0 numbers is Undefined");
    }
    return 0;
}

PAT 1054. 求平均值

标签:main   pac   tde   无法   空格   格式   dex   aaa   amp   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8135075.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!