码迷,mamicode.com
首页 > 其他好文 > 详细

分支-12. 计算火车运行时间

时间:2014-09-17 13:26:22      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   java   ar   strong   for   div   art   

本题要求根据火车的出发时间和达到时间,编写程序计算整个旅途所用的时间。

输入格式:输入在一行中给出2个4位正整数,其间以空格分隔,分别表示火车的出发时间和到达时间。每个时间的格式为2位小时数(00-23)和2位分钟数(00-59),

假设出发和到达在同一天内。

输出格式:在一行输出该旅途所用的时间,格式为“hh:mm”,其中hh为2位小时数、mm为2位分钟数。

输入样例:1201 1530
输出样例:03:29
import java.util.Scanner;
import java.text.DecimalFormat;  
public class Main 
{
    public static void main(String[] args)
    {
        DecimalFormat df = new DecimalFormat("00");
        Scanner input = new Scanner(System.in);
        int start = input.nextInt();
        int end = input.nextInt(); 
        int hh1 =  (int)(start / 100);
        int hh2 =  (int)(end / 100);
        int mm1 = start - hh1 * 100;
        int mm2 = end - hh2 * 100;
        if(mm2 >= mm1)
            System.out.print(df.format(hh2 - hh1)+":"+df.format(mm2 - mm1));
        else
            System.out.print(df.format(hh2 - hh1 -1)+":"+df.format(mm2 + 60 - mm1));    
    }
}

 

分支-12. 计算火车运行时间

标签:style   blog   color   java   ar   strong   for   div   art   

原文地址:http://www.cnblogs.com/lsgcoder101/p/3976785.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!