码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构与算法问题 二叉排序树

时间:2014-09-17 16:50:22      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:style   color   io   os   ar   strong   for   数据   sp   

题目描述:

        二叉排序树,也称为二叉查找树。可以是一颗空树,也可以是一颗具有如下特性的非空二叉树:


        1. 若左子树非空,则左子树上所有节点关键字值均不大于根节点的关键字值;
        2. 若右子树非空,则右子树上所有节点关键字值均不小于根节点的关键字值;
        3. 左、右子树本身也是一颗二叉排序树。


  现在给你N个关键字值各不相同的节点,要求你按顺序插入一个初始为空树的二叉排序树中,每次插入后成功后,求相应的父亲节点的关键字值,如果没有父亲节点,则输出-1。

输入:

输入包含多组测试数据,每组测试数据两行。
第一行,一个数字N(N<=100),表示待插入的节点数。
第二行,N个互不相同的正整数,表示要顺序插入节点的关键字值,这些值不超过10^8。

输出:

输出共N行,每次插入节点后,该节点对应的父亲节点的关键字值。

样例输入:
5
2 5 1 3 4

样例输出:

-1

2

2

5

3


#include <iostream>
using namespace std;
struct bitree
{
	int data, parent_num;
	bitree *lchild, *rchild;
};
void insert(bitree *root_,bitree * &root, int & data)
{
	if (!root)
	{
		root = new bitree;
		root->data = data;
		root->lchild = NULL;
		root->rchild = NULL;
		root->parent_num =root_->data;
	}
	if (data > root->data)
	{
		insert(root, root->rchild, data);
	}
	if (data < root->data)
	{
		insert(root, root->lchild, data);
	}
}

void inorder(bitree * &root)
{
	if (root)
	{
		cout << root->parent_num << endl;
		inorder(root->lchild);
		inorder(root->rchild);
	}
}

int main()
{
	bitree *root = NULL;
	int n;
	cin >> n;
	int *a = new int[n];
	for (int i = 0; i < n; i++)
		cin >> a[i];
	if (!root)
	{
		root = new bitree;
		root->data = a[0];
		root->lchild = NULL;
		root->rchild = NULL;
		root->parent_num = -1;
	}
	for (int i = 1; i < n;i++)
		insert(root,root, a[i]);
	inorder(root);
	return 0;
}


数据结构与算法问题 二叉排序树

标签:style   color   io   os   ar   strong   for   数据   sp   

原文地址:http://blog.csdn.net/leviathan_/article/details/39344613

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!