码迷,mamicode.com
首页 > 其他好文 > 详细

【水】wikioi2793教官的游戏

时间:2014-09-17 18:15:42      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   strong   数据   

2793 教官的游戏

题目描述 Description

有N个学生刚吃完饭,准备出食堂。

国防学校有个规矩:必须2人一排或3人一列离开。

两个教官A,B轮流取2或3人,谁先取完谁就赢得游戏。(A先取)

若两人都用最优策略,谁会赢?

输入描述 Input Description

N

输出描述 Output Description

A赢输出1;

B赢输出-1;

平局输出0;

若人数为负,则教官NC了,输出120.(该打120了)

样例输入 Sample Input

7

样例输出 Sample Output

1

数据范围及提示 Data Size & Hint

N<=10000.

思路

水题,只是看到钻石级才随手做的

代码

#include<iostream>
#include<cstdlib>
#include<cstdio>
using namespace std;
int main()
{
    long long n;
    cin>>n;
    if (n<0) {cout<<"120"<<endl; return 0;}
    if ((n%5)==2) {cout<<1<<endl; return 0;}
    if ((n%5)==3) {cout<<1<<endl; return 0;}
    if ((n%5)==0) {cout<<"-1"<<endl; return 0;}
    cout<<0<<endl;
    return 0;
}

结果

bubuko.com,布布扣

 

【水】wikioi2793教官的游戏

标签:des   style   blog   http   color   io   os   strong   数据   

原文地址:http://www.cnblogs.com/seekdreamer/p/3977559.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!