码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1005. Spell It Right

时间:2018-01-04 00:25:00      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:contain   com   lin   space   markdown   log   str   out   put   

PAT 1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码如下

#include<iostream>
#include<vector>
using namespace std;
int main(){
    vector<string> map{"zero","one","two","three","four",
                       "five","six","seven","eight","nine"};
    string s;
    cin>>s;
    int sum=0;
    for(int i=0;i<s.size();i++)
    sum+=s[i]-'0';
    s=to_string(sum);
    for(int i=0;i<s.size();i++)
    i>0?cout<<" "<<map[s[i]-'0']:cout<<map[s[i]-'0'];
    return 0;
}

PAT 1005. Spell It Right

标签:contain   com   lin   space   markdown   log   str   out   put   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8186209.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!