码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1016. Phone Bills

时间:2018-01-06 22:13:01      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:structure   eterm   logs   not   code   positive   vector   pen   red   

PAT 1016. Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers‘ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 10 CYLL 01:01:06:01 on-line CYLL 01:28:16:05 off-line CYJJ 01:01:07:00 off-line CYLL 01:01:08:03 off-line CYJJ 01:01:05:59 on-line aaa 01:01:01:03 on-line aaa 01:02:00:01 on-line CYLL 01:28:15:41 on-line aaa 01:05:02:24 on-line aaa 01:04:23:59 off-line
Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

分析

将给出的数据先按照姓名排序,再按照时间的先后顺序排列,这样遍历的时候,前后两个名字相同且前面的状态为on-line后面一个的状态为off-line的就是合格数据
还有就是如果一个人的账单为0,就不要输出他的任何信息了;


本人的丑代码

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
#include<iomanip>
using namespace std;
vector<int> minute(24,0);
vector<int> hour(24,0);
int day=0;
struct node{
    string time;
    string state;
};
struct people{
    string name="";
    vector<node> record;
};
bool compare(node n1,node n2){
    return n1.time<n2.time;
}
double getpay(string time1,string time2){  // 计算每一次电话收费
    double p=0;
    p-=stoi(time1.substr(9,11))*minute[stoi(time1.substr(6,8))];
    p+=stoi(time2.substr(9,11))*minute[stoi(time2.substr(6,8))];
    int hours=stoi(time2.substr(3,5))*24+stoi(time2.substr(6,8))
                -stoi(time1.substr(3,5))*24-stoi(time1.substr(6,8));
    int m=stoi(time1.substr(6,8));
    for(int i=0;i<hours;i++){
        p+=hour[m%24];
        m++;
    }
    cout<<time1.substr(3,11)<<" "<<time2.substr(3,11)<<" "
    <<hours*60+stoi(time2.substr(9,11))-stoi(time1.substr(9,11))<<" $"<<fixed<<setprecision(2)<<p/100<<endl;
    return p/100;
}
int main(){
    for(int i=0;i<24;i++){
        cin>>minute[i];
        hour[i]=60*minute[i];
        day+=hour[i];
    }
    int N; cin>>N;
    map<string,people> person;
    string name,time,state,month;
    for(int i=0;i<N;i++){
        node n;
        cin>>name>>n.time>>n.state;
        month=n.time.substr(0,2);
        person[name].name=name;
        person[name].record.push_back(n);
    }
    double pay;
    for(auto it=person.begin();it!=person.end();it++){
         double sum=0.0,tag=0;
        sort(it->second.record.begin(),it->second.record.end(),compare);
        for(int i=1;i<it->second.record.size();i++){
        if(it->second.record[i-1].state=="on-line"&&it->second.record[i].state=="off-line"){ // 判断是否是合格的数据
            if(tag++==0) cout<<it->first<<" "<<month<<endl;
            pay=getpay(it->second.record[i-1].time,it->second.record[i].time);
            sum+=pay;
            }
        }
        if(tag!=0) 
        cout<<"Total amount: $"<<fixed<<setprecision(2)<<sum<<endl;
    }
    return 0;
}

大神的漂亮代码

#include <iostream>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
struct node {
    string name;
    int status, month, time, day, hour, minute;
};
bool cmp(node a, node b) {
    return a.name != b.name ? a.name < b.name : a.time < b.time;
}
double billFromZero(node call, int *rate) {
    double total = rate[call.hour] * call.minute + rate[24] * 60 * call.day;
    for (int i = 0; i < call.hour; i++)
        total += rate[i] * 60;
    return total / 100.0;
}
int main() {
    int rate[25] = {0}, n;
    for (int i = 0; i < 24; i++) {
        scanf("%d", &rate[i]);
        rate[24] += rate[i];
    }
    scanf("%d", &n);
    vector<node> data(n);
    for (int i = 0; i < n; i++) {
        cin >> data[i].name;
        scanf("%d:%d:%d:%d", &data[i].month, &data[i].day, &data[i].hour, &data[i].minute);
        string temp;
        cin >> temp;
        data[i].status = (temp == "on-line") ? 1 : 0;
        data[i].time = data[i].day * 24 * 60 + data[i].hour * 60 + data[i].minute;
    }
    sort(data.begin(), data.end(), cmp);
    map<string, vector<node> > custom;
    for (int i = 1; i < n; i++) {
        if (data[i].name == data[i - 1].name && data[i - 1].status == 1 && data[i].status == 0) {
            custom[data[i - 1].name].push_back(data[i - 1]);
            custom[data[i].name].push_back(data[i]);
        }
    }
    for (auto it : custom) {
        vector<node> temp = it.second;
        cout << it.first;
        printf(" %02d\n", temp[0].month);
        double total = 0.0;
        for (int i = 1; i < temp.size(); i += 2) {
            double t = billFromZero(temp[i], rate) - billFromZero(temp[i - 1], rate);
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", temp[i - 1].day, temp[i - 1].hour, temp[i - 1].minute, temp[i].day, temp[i].hour, temp[i].minute, temp[i].time - temp[i - 1].time, t);
            total += t;
        }
        printf("Total amount: $%.2f\n", total);
    }
    return 0;
}

PAT 1016. Phone Bills

标签:structure   eterm   logs   not   code   positive   vector   pen   red   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8215255.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!