码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2505 A multiplication game

时间:2018-01-07 16:08:15      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:data-   hat   ret   str   注意   span   scanf   zoj   name   

                                                    A multiplication game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6421   Accepted: 3225

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either 
Stan wins. 
or 
Ollie wins. 
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

Source

 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
#define maxn 10005
using namespace std;
ll n,tot,val;
ll num[maxn],pos[20];
ll to[maxn][20];
bool win[maxn];

inline void prework(){
    tot=0;
    for(ll i=1;i<n;i<<=1)
        for(ll j=i;j<n;j*=3ll)
            for(ll k=j;k<n;k*=5ll)
                for(ll l=k;l<n;l*=7ll) num[++tot]=l;
    sort(num+1,num+tot+1);
    
    memset(pos,0,sizeof(pos));
    memset(win,0,sizeof(win));
    
    for(int i=1;i<=tot;i++){
    //    to[i][1]=i;
        for(int j=2;j<=9;j++){
            val=num[i]*(ll)j;
            while(pos[j]<tot&&num[pos[j]]<val) pos[j]++;
            to[i][j]=(num[pos[j]]==val?pos[j]:0);
        }
    }
}

int main(){
    while(scanf("%lld",&n)==1&&n){
        prework();
        
        for(int i=tot;i;i--){
            for(int j=2;j<=9;j++) if(!to[i][j]||(to[i][j]&&!win[to[i][j]])){
                win[i]=1;
                break;
            }
        }
        
        if(win[1]) puts("Stan wins.");
        else puts("Ollie wins.");
    }
    
    return 0;
}

 

POJ 2505 A multiplication game

标签:data-   hat   ret   str   注意   span   scanf   zoj   name   

原文地址:https://www.cnblogs.com/JYYHH/p/8227894.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!