码迷,mamicode.com
首页 > 其他好文 > 详细

AC日记 - - - 8

时间:2018-01-13 22:18:48      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:结束   不为   程序   content   post   math.h   pre   amp   bre   

Description

整数序列是一串按特定顺序排列的整数,整数序列的长度是序列中整数的个数,不可定义长度为负数的整数序列。

两整数序列A、B的和定义为一个新的整数序列C,序列C的长度是A、B两者中较长的一个,序列C的每个位置上的整数都是A、B对应位置之和。若序列A、B不等长,不妨假设A比B整数多,那么序列C中多出B的那部分整数视作A的对应位置上的整数与0相加。

你的任务是计算符合某些要求的整数序列的和,这些序列中的整数都是小于1000的非负整数。

Input

输入的第一行为一个整数M(M>0),后面有M行输入。每行输入为不超过1000个整数的整数序列,每个整数序列的输入均以0结束。

Output

对输入的整数序列两两相加:第1行和第2行相加、第3行和第4行相加……按顺序输出结果:每行输出一个整数序列,每两个整数之间用一个空格分隔。若序列数目不为偶数,则视作补一个长度为0的整数序列相加。

值得注意的是一个长度为0的整数序列也应该有输出,即使没有整数输出,也应该占有一行,因为“每行输出一个整数序列”。

Sample Input

3 1 2 3 0
10 15 20 30 50 0
100 200 300 400 0

Sample Output

11 17 23 30 50
100 200 300 400

HINT

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
int main()
{
    int n, i, i1, i2, j1=0, j2=0, temp1, temp2, l, t;
    int a[1100]={0}, b[1100]={0}, c[1100]={0};
    scanf("%d", &n);
    for(i=1; i<=n; i++)
    {
        j1=0;j2=0;
        if(i%2!=0)
        {
            while(scanf("%d", &temp1)!=EOF)
            {
                if(temp1!=0)
                {
                     a[j1]=temp1;
                     j1++;
                }
                if(temp1==0)
                    break;//★  要不然停不了。。
            }

        }
        if(i%2==0)
        {
            while(scanf("%d", &temp2)!=EOF)
            {
                if(temp2!=0)
               {
                 b[j2]=temp2;
                 j2++;
               }
               if(temp2==0)
                break;//★ 
            }

            if(j1>j2)
                l=j1;
            else
                l=j2;
            for(t=0;t<l;t++)
            {
                if(t==0)
                printf("%d",a[t]+b[t]);
                else
                printf(" %d", a[t]+b[t]);
            }
            printf("\n");
        }
        if(i==n&&n%2!=0)
        {
            for(t=0;t<j1;t++)
            {
                if(t==0)
                printf("%d", a[t]);
                else
                printf(" %d", a[t]);
            }
            printf("\n");
        }

    }
}

  

这里最少要用到一个数组来存数整数序列或整数序列的和。一个省事的做法是把数组定义的稍微大一点,因为有时你的程序可能会边界处理的不是太好。

AC日记 - - - 8

标签:结束   不为   程序   content   post   math.h   pre   amp   bre   

原文地址:https://www.cnblogs.com/Jie-Fei/p/8280416.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!