码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1027. Colors in Mars

时间:2018-01-15 18:51:07      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:code   lin   iostream   inpu   mat   number   mes   com   test   

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71

Sample Output

123456

分析
把给的10进制的数都转化为13进制

#include<iostream>
using namespace std;
int main(){
    int i,j,k;
    cin>>i>>j>>k;
    char ch[14]={"0123456789ABC"};
    cout<<"#"<<ch[i/13]<<ch[i%13]<<ch[j/13]<<ch[j%13]<<ch[k/13]<<ch[k%13]<<endl;
    return 0;
}

PAT 1027. Colors in Mars

标签:code   lin   iostream   inpu   mat   number   mes   com   test   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8289103.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!