码迷,mamicode.com
首页 > 其他好文 > 详细

1083. List Grades (25)

时间:2018-01-17 00:44:49      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:distinct   instead   post   ios   struct   blog   line   jea   ted   

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade‘s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student‘s name and ID, separated by one space. If there is no student‘s grade in that interval, output "NONE" instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct stu
{
    int score;
    char name[10],id[20];
}s[100000];
bool cmp(stu a,stu b)
{
    return a.score > b.score;
}
int main()
{
    int n,a,b;
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
    {
        scanf("%s %s %d",s[i].name,s[i].id,&s[i].score);
    }
    scanf("%d%d",&a,&b);
    sort(s,s + n,cmp);
    int c = 0;
    for(int i = 0;s[i].score >= a && i < n;i ++)
    {
        if(s[i].score <= b)
        {
            c ++;
            printf("%s %s\n",s[i].name,s[i].id);
        }
    }
    if(!c)printf("NONE");
}

 

1083. List Grades (25)

标签:distinct   instead   post   ios   struct   blog   line   jea   ted   

原文地址:https://www.cnblogs.com/8023spz/p/8297467.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!