码迷,mamicode.com
首页 > 其他好文 > 详细

1097. Deduplication on a Linked List (25)

时间:2018-01-17 20:17:26      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:int   position   scan   des   ase   clu   lin   line   turn   

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

#include<iostream>
using namespace std;
#include<vector>
#include<algorithm>
#include<cmath>
#include<cstdio>
struct node{
	int addr;
	int key;
	int next;
};
int main(){
	vector<node>first;
	vector<node>dedup;
	vector<node>list(100000);
	vector<int>flag(10001,-1);
	int s,n;
	scanf("%d%d",&s,&n);
	int addr,key,next;
	int i,j,k;
	for(i=0;i<n;i++){
		scanf("%d%d%d",&addr,&key,&next);
		list[addr].addr=addr;
		list[addr].key=key;
		list[addr].next=next;
	}
	if(s==-1){
		printf("\n");
		return 0;
	}
	addr=s;
	while(addr!=-1){
		if(flag[abs(list[addr].key)]==-1){
			first.push_back(list[addr]);
			flag[abs(list[addr].key)]=0;
		}else{
			dedup.push_back(list[addr]);
		}
		addr=list[addr].next;
	}
	node no;
	int size = first.size();
	for(i=0;i<size-1;i++){
		no = first[i];
		printf("%05d %d %05d\n",no.addr,no.key,first[i+1].addr);
	}
	no = first[i];
	printf("%05d %d -1\n",no.addr,no.key);
	
	size = dedup.size();
	if(size==0){
		return 0;
	}
	for(i=0;i<size-1;i++){
		no = dedup[i];
		printf("%05d %d %05d\n",no.addr,no.key,dedup[i+1].addr);
	}
	no = dedup[i];
	printf("%05d %d -1\n",no.addr,no.key);
	return 0;
}

  

1097. Deduplication on a Linked List (25)

标签:int   position   scan   des   ase   clu   lin   line   turn   

原文地址:https://www.cnblogs.com/grglym/p/8304888.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!