码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1426:Find The Multiple(算是bfs水题吧,投机取巧过的)

时间:2014-09-18 20:27:14      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   strong   

http://poj.org/problem?id=1426

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

大致题意:

给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m必须只由十进制的‘0‘或‘1‘组成。

没看见是Special Judge
题解:
我感觉这题能够是投机取巧,输出结果根本就没有100位,之前以为是大数,一直没敢做,谁知是一个超级大坑题。
还有给的测试数据给的那么大,害我一看测试数据就不敢做了。还有为什么我用STL中的queue用C++交超时,而用G++就A了
,而自己写的结构体用C++交就过了。
主要思想:
和二叉树差不多,1->10,11;10->100,101,11->110,111.....
就是q.push(t*10);q.push(t*10+1);
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
int n;
struct node
{
    long long int x;
} q[10000001];
struct node t,f;
void bfs()
{
    int s=0;
    int e=0;
    t.x=1;
    q[e++]=t;
    while(s<e)
    {
        t=q[s++];
        if(t.x%n==0)
        {
            printf("%lld\n",t.x);
            break;
        }
        f.x=t.x*10;
        q[e++]=f;
        f.x=t.x*10+1;
        q[e++]=f;
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        bfs();
    }
    return 0;
}

 G++;

bubuko.com,布布扣
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <queue>
using namespace std;
int n;
long long t;
void bfs()
{
    queue<long long >q;
    q.push(1);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t%n==0)
        {
            printf("%lld\n",t);
            break;
        }
        q.push(t*10);
        q.push(t*10+1);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        bfs();
    }
    return 0;
}
View Code

 

POJ1426:Find The Multiple(算是bfs水题吧,投机取巧过的)

标签:des   style   blog   http   color   io   os   ar   strong   

原文地址:http://www.cnblogs.com/zhangmingcheng/p/3979955.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!