码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1789 Doing Homework again

时间:2018-01-23 22:08:33      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:i++   red   space   memory   ==   oid   acm   ott   pos   

一、题目概述

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15842    Accepted Submission(s): 9219


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

 

Sample Output
0 3 5
 
 

二、题目释义

有n门课,每一门课有一个限定的时间和超过时间后罚的分数,然后假定每一天只能完成一门课,问如何安排时间去完成这些课,使得罚分最少并输出。

三、思路分析

罚分大的必须要做,未必是最先的但是必须要做,由此有两种贪心策略,第一对让罚分大的尽可能靠近它的截止日期来完成,二是让截止日期靠前的尽可能多完成

四、AC代码

对罚分进行排序

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int N = 1005;

struct course
{
    int dl, scr;

} data[N];

int vis[N];

int cmp (course a, course b)
{
    if (a.scr != b.scr)
        return a.scr > b.scr;
    else return a.dl < b.dl;
}

int main ()
{
    int T;
    scanf ("%d", &T);
    while (T--)
    {
        int n;
        memset (vis, 0, sizeof(vis));
        scanf ("%d", &n);
        for (int i=0; i<n; i++)
            scanf ("%d", &data[i].dl);
        for (int i=0; i<n; i++)
            scanf ("%d", &data[i].scr);
        sort (data, data+n, cmp);
        int ans = 0;
        for (int i=0; i<n; ++i)
        {
            int day = data[i].dl;
            for (; day>=1; day--)
                if(!vis[day])
                {
                    vis[day] = 1;
                    break;
                }
            if(day == 0)
                ans += data[i].scr;
        }
        printf ("%d\n", ans);
    }
    return 0;
}

对截止日期进行排序

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const int N = 1005;

struct course
{
    int dl,rs;
}a[N];
int flag[N];

void init()
{
    memset(flag,0,sizeof(flag));
}

bool cmp(course& A, course& B)
{
    if(A.dl == B.dl) return A.rs > A.rs;
    return A.dl < B.dl;
}

int main()
{
    int T,n; cin >> T;
    while(T--)
    {
        init();
        cin >> n;
        for(int i=0; i<n; i++)
            cin >> a[i].dl;
        for(int i=0; i<n; i++)
            cin >> a[i].rs;
        sort(a,a+n,cmp);
        int d = 1, sum = 0;
        for(int i=0; i<n; i++)
        {
            if(a[i].dl>=d) {flag[i]=1; d++;}
            else
            {
                int Min = a[i].rs;
                int t = i;
                for(int j=i-1; j>=0; j--)
                {
                    if(flag[j]==1 && a[j].rs<Min)
                    {
                        Min = a[j].rs;
                        t=j;
                    }
                }
                sum += a[t].rs;
                a[t].rs = a[i].rs;
            }
        }
        cout << sum << endl;
    }
    return 0;
}

HDU 1789 Doing Homework again

标签:i++   red   space   memory   ==   oid   acm   ott   pos   

原文地址:https://www.cnblogs.com/EcliWalker/p/8324986.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!