码迷,mamicode.com
首页 > 其他好文 > 详细

poj2356鸽舍原理

时间:2018-01-27 11:19:17      阅读:104      评论:0      收藏:0      [点我收藏+]

标签:std   class   body   some   each   ring   while   with   may   

        The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3
#include<stdio.h>
#include<string.h>
int n,c;
int a[100010],b[100010],vis[100010],sum[100010];
int main()
{

    while(scanf("%d",&n)!=EOF)
    {
        int x,y;
        memset(vis,-1,sizeof(vis));
        memset(sum ,0,sizeof(sum));
        vis[0] = 0;//前i项可以被c整除
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            sum[i]=(a[i]+sum[i-1])%n;
            if(vis[sum[i]]==-1)
                vis[sum[i]] = i;
            else
            {
                x = vis[sum[i]];//vis[sum[i]] = i;记录了上一次的i
                y = i;
            }
        }
            printf("%d\n",y-x);
            for(int i = x+1;i <= y;i++)
                    printf("%d\n",a[i]);
    }
    return 0;
}

 

poj2356鸽舍原理

标签:std   class   body   some   each   ring   while   with   may   

原文地址:https://www.cnblogs.com/--lr/p/8362525.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!