码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1059. Prime Factors

时间:2018-01-27 13:49:53      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:log   include   ==   its   输入   each   down   isp   bool   

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 pm^km, where pi‘s are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291

分析

在输入的数据为1时输出1=1;
#include<iostream>
#include<math.h>
#include<map>
using namespace std;
bool isprime(long int n){
    for(int i=2;i<=sqrt(n);i++)
        if(n%i==0) return false;
    return true;
}
int main(){
    long int p,t=1,q;
    cin>>p;
    q=p;
    map<long int,int> mapp; 
    for(int i=2;i<=p;i++){
        while(isprime(i)&&p%i==0){
             p/=i;
             t*=i;
             mapp[i]++;
        }
        if(t==q) break;
    }
    printf("%d=",q);
    if(q==1) printf("1");
    for(auto it=mapp.begin();it!=mapp.end();it++){
        if(it!=mapp.begin()) 
           printf("*");
        if(it->second==1)
           printf("%d",it->first);
        else
           printf("%d^%d",it->first,it->second);
    }
    return 0;
} 

PAT 1059. Prime Factors

标签:log   include   ==   its   输入   each   down   isp   bool   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8365366.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!