码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1065. A+B and C

时间:2018-01-28 12:43:10      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:star   strong   amp   sed   spec   cas   分析   using   cin   

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

分析

这道题参考了别人的代码
因为A、B的大小为[-2^63, 2^63],用long long 存储A和B的值,以及他们相加的值sum:
如果A > 0, B < 0 或者 A < 0, B > 0,sum是不可能溢出的
如果A > 0, B > 0,sum可能会溢出,sum范围理应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2]是个负数,所以sum < 0时候说明溢出了
如果A < 0, B < 0,sum可能会溢出,同理,sum溢出后结果是大于0的,所以sum > 0 说明溢出了
#include<iostream>
using namespace std;
int main(){
    long long a,b,c,sum;
    int n;
    cin>>n;
    for(int i=1;i<=n;i++){
        cin>>a>>b>>c;
        sum=a+b;
        if(a>0&&b>0&&sum<0)
           printf("Case #%d: true\n", i);
        else if(a<0&&b<0&&sum>=0)
           printf("Case #%d: false\n", i);
        else if(sum>c)
           printf("Case #%d: true\n", i);
        else
           printf("Case #%d: false\n", i);
    }
    return 0;
} 

PAT 1065. A+B and C

标签:star   strong   amp   sed   spec   cas   分析   using   cin   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8370614.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!