码迷,mamicode.com
首页 > 其他好文 > 详细

P2871 [USACO07DEC]手链Charm Bracelet

时间:2018-01-28 18:16:30      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:actor   技术   eve   printf   each   possible   个数   can   fill   

题目描述

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

第一行:物品个数N和背包大小M

第二行至第N+1行:第i个物品的重量C[i]和价值W[i]

 

输出格式:

 

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

输出一行最大价值。

 

输入输出样例

输入样例#1: 复制
4 6
1 4
2 6
3 12
2 7
输出样例#1: 复制
23

技术分享图片
//二维DP会 炸 
//WA 80
#include<bits/stdc++.h>
#define N 12881
using namespace std;
int n,m,w[N],v[N],dp[N]; 
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&w[i],&v[i]);
    for(int i=1;i<=n;i++)
        for(int j=0;j<=m;j++)
        {
            if(j<w[i])
                dp[i][j]=dp[i-1][j];
            else 
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);
        }
    cout<<dp[n][m];
}
View Code
技术分享图片
//一维DP AC
#include<bits/stdc++.h>
#define N 50000
using namespace std;
int n,m,w[N],v[N],dp[N]; 
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&w[i],&v[i]);
    for(int i=1;i<=n;i++)
        for(int j=m;j>0;j--)
        {
            if(j>=w[i])
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        }
    printf("%d",dp[m]);
}
View Code

//01背包板子题

P2871 [USACO07DEC]手链Charm Bracelet

标签:actor   技术   eve   printf   each   possible   个数   can   fill   

原文地址:https://www.cnblogs.com/song-/p/8371673.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!